New features in Microsoft Access XP 

There is no real significant change at the basic level. Basic users will not be inconvenienced by a move to XP, whereas experienced users may wish to embrace some of the new or enhanced features. The software should be more solid and run quicker. To help you understand which version you are on- Access XP is also known as 2002 or version 10, Access 2000 is version 9.

System Requirements

· None of the XP software will run on Windows NT or Windows 95. Recommended operating system is Windows 2000 Professional or later

· All XP software requires Microsoft Internet Explorer to be installed because they take advantage of services provided by the browser. It does not have to be the default browser. By default, Internet Explorer 5.01 is installed when the System files update is performed.

· Pentium 133 MHz or higher required (Access 2000 75MHz)

· 64Mb of RAM is the required minimum plus 8Mb for each application running simultaneously (same as 2000), 128Mb recommended

· 245Mb available hard disk space is required for the default configuration of XP Professional, plus 50Mb for each additional language interface installed (Access 2000 required 200Mb)

New look 

Microsoft Access XP has changed the interface a little as well as changing to softer colours (for example, the main database window is now pale grey rather than dark grey). 

Different access to Help 

By default, the Assistant is now not visible (use the Help menu to make it visible). There is a new Ask a Question box on top right hand corner of the menu bar. This must be used in conjunction with the enter key (using the tab key forgets the question). This enables you to see a list of choices and read a Help topic, and see the index and answer wizard, whether you are running the Office Assistant or not. If you use the help icon now, you only see table of contents- nothing is shown for answer wizard or index so help is more cumbersome. 

· Click the Send and go to the Web button at the bottom of the help screen having asked a question and not been given the answer, to start your Web browser 
· send your question to a site that provides further assistance. 
Also applies to other Office software.

Office task panes 

The most common tasks in Microsoft Office are now organized in panes that display while your file is open. Use the dropdown box at the top of the pane to display the different panes. Panes available are:

· Search- to find files containing specified words, whether they are in the body of the file, in keywords or in other file properties. The file type can be specified. This pane can also be opened by selecting Search from the File menu.

· Clipboard gallery of copied items (this can be shown as an icon)- display by selecting Office Clipboard from the Edit menu or by pressing Control C twice. Display options can be specified by using the Options button under the clipboard pane.

· New File – to open a new or existing file.

The Access task pane is displayed by default when Access is opened, and gives the options of:

· opening a file
· creating a new database
· create a new database from an existing database or existing template (database, data access page or project)
· adding a network place 
· using help. 
You will probably want to switch the pane off, and display when required by: 
1. On the Tools menu, click Options. 
2. Click the View tab. 

3. Under Show, select or clear the Startup Task Pane check box. 

Multiple Undo and Redo

You now have the ability to undo and redo multiple actions in Design view in all objects in your databases when you perform Edit/ Undo. Up to now, it has only been possible to undo the last design action.

Error Prevention and recovery

Document recovery and safer shutdown 

Documents you are working on can be recovered if the program encounters an error or stops responding. The documents are displayed in the Document Recovery task pane the next time you open the program.

Office Safe Mode 

Microsoft Office XP programs can detect and isolate startup problems. Microsoft Office Safe Mode allows you to safely use an Office program that has encountered certain startup problems such as an add-in or extension that won't start, or a corrupted resource, file, registry, or template. A message is displayed the next time the program is started, identifying the problem and asking if you want to disable the part of the program that has a problem. When a problem is detected at startup, Office either fixes the problem or isolates it, allowing the program to start successfully.
· Select About Microsoft <program> from the Help menu

· Press the Disabled Items button to obtain a list of disabled items

· You can use the dialog box to enable the listed items. Enabling some items may require you to reload or reinstall an add-in program or reopen a file. Enabling an item does not necessarily fix the root problem; an item that you enable may be placed back on the disabled list the next time you start the program.

Increased protection against macro viruses 

Network administrators can remove Microsoft Visual Basic for Applications, the programming language of Microsoft Office, when deploying Office. This can decrease the possibility of viruses spreading via Office documents. This is not very sensible for Access if you have default buttons!

Round-tripping

There are now two database file formats. You can now work with and modify Access 2000 files in Access 2002 without converting the file format. This allows you to share different versions of database files with other Access users. It is recommended that you should stick to Access 2000 format at present, because Access 2002 format may not be accessed by Access 2000 users, so do not change until all your colleagues are using the same version of Access. Access 2002 format is in XML so that it can support it and connect to XML sources.

· To convert to a different database format 

· use: Tools/database utilities/convert 

· select Access97, 2000 or 2002

· To specify the database format to use when creating a new database, use:

· Tools/options/Advanced/File format 

· Select Access 2000 or Access 2002 format

Do this before creating a new database (the option is not available if a database is not open)

Conversion Error Logging

If problems are encountered when converting from Access 95 and later versions, Access 2002 will now create the Conversion Errors table that lists information about each error, making it much easier to identify and solve problems. The table contains the following columns:
Object Type The type of database object in which Access encountered an error, or "Database" if Access encountered an error that is not specific to a particular type of object.

Object Name The name of the object in which Access encountered an error. If Access encounters a compilation error during conversion, however, the name of the module that contains the error is not specified.

Error Description If necessary, you can press SHIFT+F2 to view the entire description of the error.

Subforms/Subreports Design view

You can now open subforms or subreports in their own Design view window directly from within the main form or report or from the View menu, as well as separately. Scrolling has also been improved so that it is easier to work with subforms and subreports in Design view.

Additional shortcuts and zoom features

Access 2002 now provides more key shortcuts when working with forms and reports.

· Pressing F8 in form or report Design will now display the field list. 

· Pressing ENTER after selecting a field in the field list in form or report Design view will automatically add the field to the form or report design surface. 

· Pressing CTRL+TAB will move the focus from a form or report section to a subsection. 

· Two additional powers (1000% and 500%) have been added to the Zoom option in print preview. 

Updated Clip Organizer 

Hundreds of new clips, a task pane interface, as well as the same abilities to organize clips and find new digital art on the Web are part of the updated Clip Organizer (formerly Clip Gallery). However, Microsoft Access XP still appears to be using Clip Gallery by default (which has different clips), even though Microsoft Word XP is using Clip Organiser. This is due to an error in the registry. You can find the Clip Organizer by:

· from the Start menu, look at Microsoft Office Tools from the Microsoft Office XP menu

· You can then look at your own collection, Office collections or Web collections, and use a search menu to look for clips using keywords.

· You can then copy the appropriate image 

Support for handwriting

You can use handwriting recognition to enter text into an Office document using a handwriting input device such as a graphics tablet or a tablet-PC, or your mouse. Your natural handwriting is converted to typed characters (in Word, you can choose to leave text in handwritten form -Graphics tablet recommended). This feature is available in the Simplified Chinese, Traditional Chinese, English, Japanese, and Korean language versions of Microsoft Office. However, the handwriting toolbar is not included in Microsoft Access
Speech: Voice commands and dictation 

In addition to mouse and keyboard methods, you can now select menu, toolbar, and dialog box items by speaking. You can also dictate text. This feature is available in the Simplified Chinese, English (U.S.), and Japanese language versions of Microsoft Office, and has some special hardware and installation requirements. 

· Pentium 400MHz required and 128 RAM. Sound card not required as this is handled by the microphone device (which should conform to PC99 System Design standards)

· Make sure Speech is installed. Speech recognition is installed in all Office programs by initially using the feature in Microsoft Word and selecting Speech from the Tools menu, or by doing a custom installation.
· Adjust your microphone, and make sure speakers properly connected

· Select speech from the Tools menu. A wizard guides you through the process. To train Office for speech recognition, you need a quiet room, and at least 15 minutes. 

· Click voice command on the language toolbar and say the name of any menu or toolbar you can see

Language-specific features

These features are only available if you have installed the Microsoft Office XP Multilingual User Interface Pack or Microsoft Office Proofing Tools for the specific language. In addition, you must enable support for the language through Microsoft Office Language Settings.

More components across Microsoft Office support changing the language of their user interface. In addition, terms on the interface match the terms in Help, even when the main text of Help is in a different language than the interface. This feature is only available with the Office XP MUI Pack and a volume licensing agreement.

Over 20,000 new characters are supported by the Hangul/Hanja converter for Korean language documents. The converter automatically uses new fonts that have the proper glyphs for the new characters. 

Full support for Windows 2000 language features 

Microsoft Office programs now support all the languages that Microsoft Windows 2000 does. Office also supports the latest extensions to Chinese character encoding via Unicode, including support for almost 70,000 Chinese characters.

East Asian character support on non-East Asian systems 

Now you can enter characters from East Asian languages in all Office programs, even if your system software is a non-East Asian language version. (This was previously only supported in Microsoft Word and Microsoft Outlook, or on Windows 2000.) For example, on a computer running English (U.S.) Microsoft Windows 98, you can enter Japanese characters in Microsoft Access. 

Improved Support for International Complex-scripts

Access 2002 now lets you switch the reading direction from left-to-right, to right-to-left, in language-specific objects. Input Method Editor (IME) is a program that enters East Asian text (Traditional Chinese, Simplified Chinese, Japanese, or Korean) into programs by converting keystrokes into complex East Asian characters. The IME is treated as an alternate type of keyboard layout.)
· Select Tools/options/keyboard/IME control for East Asian languages when entering data in a datasheet. 

· Select Tools/options/international to define right to left

· Look at the design properties (other) of a form (on a text field, list box or combo box), 

· set IMEHold (apply to Japanese only) to show 

· whether the Kanji (Chinese pictogram alphabet) Conversion Mode is maintained when the control loses focus, 

·  set IMEMode (applies to all East Asian languages) to set a control's Kanji Conversion Mode when the focus shifts to the control

Setting
Description
No Control
Kanji Conversion Mode not set (default).
On
Turns on Kanji Conversion Mode.
Off
Turns off Kanji Conversion Mode.
Disable
Disables Kanji Conversion Mode.
Hiragana
Sets full pitch hiragana
Full pitch Katakana
Sets full pitch katakana.
Half pitch Katakana
Sets half pitch katakana.
Full pitch Alpha/Num
Sets full pitch letters/numbers.
Half pitch Alpha/Num
Sets half pitch letters/numbers.
HangulFull
Sets full pitch hangul.
Hangul
Sets half pitch hangul.
· set IMESentenceMode (apply to Japanese only) to specify or determine the IME Sentence Mode to Normal (default), Plural, Speaking or No Conversion  of controls that switch when the focus moves.

· Look at the design of a Table, set IME properties (IMEMode and IMESentenceMode) for a Text, memo or hyperlink field 

PivotTable and PivotChart views 

A Pivot Table query is similar to a cross-tab query. PivotTable and PivotChart views are used to perform data analysis, and have been enhanced (these have been around since Access 2, but originally required Microsoft Excel to be launched). The advantage of a Pivot Table is that detail information can also be displayed behind the summary calculation. Each row and column heading includes plus and minus controls that are used to toggle the display of the detail information. You can also drill down to the detail for a particular summary without displaying a lot of extraneous data by double-clicking on the appropriate summary cell (hide by another double-click). Pivot Tables are still not really Microsoft Access objects at all, but embedded Microsoft Excel objects, so you must have Excel installed. They are called pivot tables since you can quickly rearrange the position of the fields. Note that the view on the Access form is limited to what you can see on the screen at one time (there is no PageDown). You may prefer to run the pivot table directly in Excel by selecting Analyze it with Excel from Tools/Office Links

· Start the PivotTable wizard when creating a new form (crosstab wizard is started when creating a new query). PivotTables let you switch row and column headings dynamically and filter data on the fly so are more powerful than crosstab queries. 

· Drag and drop the fields into the row, column and “measure” areas. Notice the new icons. 

· Because pivot tables are devices for displaying information, you can not manually change the information in the body of the table.

· PivotTable and PivotChart views can be saved as data access pages that can be viewed by Microsoft Internet Explorer 5 or later. 

· You can also use subforms in PivotTable and PivotChart views in exactly the same fashion that they are used with forms in Datasheet view now. 

· You can write code behind forms in PivotTable and PivotChart views and take advantage of new events available:
 PivotTableChange Property Returns or sets a String indicating what happens when the PivotTableChange event occurs. Read/write.

XML Support

Note that Information Services do not support XML. This information is only included for completeness.

In addition to being the standard language for describing and delivering data on the Web, Extensible Markup Language (XML) is a technology for exchanging data between applications. It allows developers to create their own customised tags, enabling the definition, transmission, validation, and interpretation of data between applications. Microsoft Access 2002 provides ways of sharing XML data regardless of differences in the platform, data format, protocol, schema, or business rules. Microsoft Access provides ways to both import and export XML data as well as transform the data to and from other formats using XML related files.

· By using Access, you can create XML data or schema documents by selecting an Access object, then select Export from the File menu, a file of type XML. You are asked whether you want to export the data to an XML file. An example of XML:

<?xml version="1.0" encoding="UTF-8"?>

<dataroot xmlns:od="urn:schemas-microsoft-com:officedata" xmlns:xsi="http://www.w3.org/2000/10/XMLSchema-instance"  xsi:noNamespaceSchemaLocation="Drugs.xsd">

<Drugs>

<DrugID>1</DrugID>

<Drug_x0020_name>Dolly mixtures</Drug_x0020_name>

<Tablets_x0020_per_x0020_packet>100</Tablets_x0020_per_x0020_packet>

<Cost_x0020_per_x0020_packet>0.49</Cost_x0020_per_x0020_packet>

</Drugs>

<Drugs>

<DrugID>2</DrugID>

<Drug_x0020_name>Creme eggs</Drug_x0020_name>

<Tablets_x0020_per_x0020_packet>10</Tablets_x0020_per_x0020_packet>

<Cost_x0020_per_x0020_packet>1.9</Cost_x0020_per_x0020_packet>

</Drugs>…………

you can optionally, use an Extensible Style Language Transformation (XSLT) to transform the XML data to another format, the schema using XML Schema Definition (XSD). XSD defines a richer set of data types such as Booleans, numbers, date and time, and currencies, so makes validation easier:

<?xml version="1.0" encoding="UTF-8"?>

<xsd:schema xmlns:xsd="http://www.w3.org/2000/10/XMLSchema" xmlns:od="urn:schemas-microsoft-com:officedata">

<xsd:element name="dataroot">

<xsd:complexType>

<xsd:choice maxOccurs="unbounded">

<xsd:element ref="Drugs"/>

</xsd:choice>

</xsd:complexType>

</xsd:element>

<xsd:element name="Drugs">

<xsd:annotation>

<xsd:appinfo>

<od:index index-name="PrimaryKey" index-key="DrugID " primary="yes" unique="yes" clustered="no"/>

<od:index index-name="did" index-key="DrugID " primary="no" unique="no" clustered="no"/>

</xsd:appinfo>

</xsd:annotation>

<xsd:complexType>

<xsd:sequence>

<xsd:element name="DrugID" od:jetType="autonumber" od:sqlSType="int" od:autoUnique="yes" od:nonNullable="yes">

<xsd:simpleType>

 or the style sheets presentation using an Extensible Style Language (XSL format): 

<TABLE BORDER="1" BGCOLOR="#ffffff" CELLSPACING="0" CELLPADDING="0"><TBODY>

<xsl:for-each select="/dataroot/Drugs">

<xsl:eval>AppendNodeIndex(me)</xsl:eval>

</xsl:for-each>

<xsl:for-each select="/dataroot/Drugs">

<xsl:eval>CacheCurrentNode(me)</xsl:eval>

<xsl:if expr="OnFirstNode">

<TR><TH style="width: 0.9375in">

DrugID

</TH>

<TH style="width: 0.875in">

Drug name

</TH>

<TH style="width: 0.9791in">

Tablets per packet

</TH>

·  You can also use XML data from other applications in your forms, reports and data access pages. For example, suppose your data is scattered across a wide variety of sources such as Excel spreadsheets, and Oracle. Since these sources use XML as their data interchange format, you could create a series of aggregation queries in Access to pull this data into views and then design forms and reports by using those views. Note that you can only import xml and xsd file type (by selecting File/ Get external data), and not link

Data Access Page HTML Designer

Note that Information Services do not support Microsoft Internet Information Server. This information is only included for completeness.

A Microsoft Access data access page is a Web page, published from Access, that has a connection to a database. In a data access page, you can view, add to, edit, and manipulate the data stored in the database. A page can also include data from other sources, such as Excel. You can save a copy of a Microsoft Access data access page to a Web server (stores files whose URLs begin with http://). This facility was introduced in Access 2000 but worked very badly and could only be viewed using Internet Explorer, and needed an Office 2000 license. Microsoft Office Web Components (OWC) need to be installed on the computer that accesses the data access pages (in the default installation). Since data access pages are actually stored in files separate from your database, Access needs to find these files on your hard disc anytime you open a page. You also need a knowledge of VBScript (not the same as the Visual Basic used in Access) or JavaScript to enhance your pages. The majority of steps must be performed on the web server, which must be correctly configured. The web server must be Microsoft Internet Information Server. Malicious users may download the database unless stored in a secure folder. You may prefer to link to HTML tables rather than use data access pages, or export to HTML.

1. In the Database window, click Pages under Objects. 

2. Double-click the data access page that you want to open. 

3. On the File menu, click Save As. 

4. In the Save Data Access Page <object name> To box, type the name of the new data access page. 

5. Under Look in in the Save As Data Access Page dialog box, click My Network Places. 

6. Click Add Network Place, select either Create a shortcut to an existing Network Place or Create a new Network Place, click Next, and then follow the instructions in the Add Network Place Wizard. 

When you save a data access page, all supporting files such as bullets, background textures, and graphics are by default organized in a supporting folder. If you move or copy your page to another location, you must also move the supporting folder so that you maintain all links to your page.
SQL Server Related

Note that Information Services do not support SQL Server. This information is only included for completeness.

Updateable Off-line Data Access Pages

You can now take the data access pages in your Access project (An Access file that connects to a Microsoft SQL Server database and is used to create client/server applications. A project file does not contain any data or data-definition-based objects such as tables and views) offline, make changes to them on your laptop, and have them automatically synchronize when you reconnect to the SQL server. Changes to the off-line pages are made to an Access project connected to a local Microsoft SQL Server 2000 Desktop Engine (formerly MSDE).

Extended Property Support with Microsoft SQL Server 2000

The built-in integration between Microsoft Access 2002 and Microsoft SQL Server 2000 has improved by the inclusion of support for extended SQL database properties from within your Access project (An Access file that connects to a Microsoft SQL Server database and is used to create client/server applications. A project file doesn't contain any data or data-definition-based objects such as tables and views). 

· By using extended properties in your Access 2002 projects, you can implement such features as lookup relationships, validation rules (also called constraints), text formatting, and subdatasheets. 

· You can use extended properties with tables, views, stored procedures, and functions, just like you can with similar objects in Access data files. 

· Using extended properties makes it easy to save column widths, row heights, fonts, and input mask settings from one Access project session to another. 

· Extended properties make it easier to migrate your business applications from Access databases to Access projects connected to Microsoft SQL Server.

Batch Updates in Access Projects using Microsoft SQL Server

You can now have Access 2002 projects batch all data entry and send it to the server when the user navigates from a record, closes a form, or selects a command. You can also create a button on your form that saves all records or undoes all changes to records, programmatically.

Password Security in an Access Project

You can now change the logon password specified in an Access project connected to a Microsoft SQL Server 6.5 or later database directly from within your Access menu.

The Linked Table Wizard

The Linked Table Wizard guides you through the process of linking your tables to a SQL Server database, and does this all from within your Access project.
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