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Introduction


This document shows how to exchange data between ORACLE, Access, Excel and Word.  Each application acts either as a client - the application requesting the information so that it can be displayed in a familiar interface, or as a server - the application supplying the information.


There are several methods to communicate with other applications:


¨	Windows Clipboard: Cutting and Pasting.  The user must physically copy the data, so there are problems of duplication (inconsistency, extra storage).  Can not be used with ORACLE data.


¨	Object Linking and Embedding (OLE ).  Allows you to stay in the same application, but access and edit objects from other applications.  Excel and Word are both OLE clients and servers so you can display both an embedded document created in Word on an Excel worksheet and embed or link portions of an Excel worksheet into Word.  Access functions only as an OLE client.  ORACLE functions only as a database server since we have not purchased their Windows products.


¨	Dynamic Data Exchange (DDE ).  This is an extension of the clipboard but retains the link between the application.  DDE automates the manual cutting and pasting of data between applications.  It enables two applications (the client and server) to talk to each other - to exchange data continually, and if you want, automatically so data can be updated.  You use Alt/Tab to switch between applications.  If you use Paste Special you can embed the clipboard contents into a Word document, or an Access form or report in a specified format (Word 6, formatted text-RTF, unformatted text or picture) or you can use a query builder tool to return and paste to the sheet.  This is simple to do but there is no direct link between ORACLE and  the Windows applications.  There are cold links (the link is broken, so you must request information each time), warm links (the server sends a message to the client when the data has changed so the client decides whether to update), or hot links (the server sends data to the client every time the data changes).  Access can act both as a DDE client or DDE server but it does not support automatic linking.  It manually updates linked data at specified intervals (click on Options from the View menu then click on MultiuserODBC).  DDE conversations are one way.  The client application is always the one that issues transactions.


In versions of OLE prior to version 2.0, it was difficult to access linked or embedded data using Microsoft Access Basic code.  For example, if you created a linked object from a Microsoft Excel spreadsheet, you could edit the spreadsheet’s data, but it was difficult to access the data using Access Basic.  With the advent of OLE Automation, you can access and manipulate the data in an OLE object, so long as the application supplying the object also supports OLE Automation.  OLE Automation objects differ from other OLE objects in that they can only be accessed using a programming or macro language.  They can not be linked or embedded since they are only temporary having been created using code.  OLE objects created using Insert Object or Paste Special are visible to the user as linked or embedded objects in bound or unbound object frames.  They can be updated by double-clicking on them.  If you want programmatic access to data in an application not supporting OLE Automation, you may still prefer to use DDE which also provides a programmatic interface.


¨	Open Database Connectivity (ODBC).  This is needed if you want to access ORACLE data from Word, Excel or Access and sits between ORACLE and the Microsoft products - hence the term middleware.


Hardware and software requirements


It is possible for other products to access ORACLE databases, as long as they have SQL*Net and the correct connectivity drivers loaded. These products include Microsoft Access and Excel. 


If you want to access ORACLE data with Microsoft products, then you will need 


¨	SQL*NET on your machine (obtainable from ORACLE or Information Services).


¨	Access needs at least 400K to attach ORACLE and will give a 6105 error.


¨	Microsoft ODBC (Open Database Connectivity) driver (version 2 upgrade obtainable from Microsoft, but the driver that came with Access 1.1 will also work). 


Performance is slow on a 4Mb machine, so it is recommended that an 8Mb machine is used (performance increased 8 fold). http://www.cse.bris.ac.uk/~ccmjs/odbc_net8.html describes how to install SQL*NET.


You should be using Word for Windows version 6 or above (version 2 does not offer database connectivity), Excel version 5 (version 4 offers Q+E an earlier version of query tool) and Access version 1.1 or above (version 2 and above offer more facilities such as  OLE Automation). 	
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Using OLE objects in Microsoft Access


An object such as an Excel spreadsheet, a Word document, or a scanned image can be embedded into a field in a table that has OLE as its datatype.  The maximum size is 1 GigaByte.  OLE object fields can not be indexed.  There are several ways to embed an OLE object in a field.  The three standard ways are: 


¨	Select Insert Object from the Edit menu to embed a new blank object or bring in a file. 


¨	Select Paste Special from the Edit menu with option Paste to be used when something has been copied from the OLE server.  The copy of the object is then embedded in the field and there is no further association maintained with the original object.


¨	Select Paste Special from the Edit menu with option Paste Link to be used when something has been copied from an OLE server, but if the original object is changed, the latest update will also be reflected in the OLE field.


OLE objects can also be added to forms and reports using the toolbox.  If you place an unbound object on the form, it is stored with the form.  If you create a bound object on the form it is stored in the underlying table.


Paste Link


When you link to an object using the Paste Link command, the Access form or report displays the object as it appears in the source application.  For example, if you link to a cell in an Excel worksheet, the field in your form or report will include all the Excel formatting.  If you want to link to just the data, you link to the contents of the cell rather than the whole object.  You can not paste anything into an ORACLE database because it is not a windows application.


ODBC Driver


The ODBC driver allows you to open and query a Microsoft Access database or ORACLE database from Access, Excel or Word for Windows.  The architecture used when opening an Access database is:


Application


|


ODBC Driver Manager (ODBC.DLL)


|


ODBC Microsoft Access Driver (SIMBA.DLL, MSJETDSP.DLL, RED11.DLL)


|


Microsoft Access database


Setting up data sources 


In Microsoft Access you can import, export and attach data in a number of different database formats and from spreadsheets and text files.  Attaching means that you are accessing the data at its source so are not duplicating it.  To connect to a particular type of data, Microsoft Access uses either an ODBC driver (for ORACLE), or a built-in driver.  If the data source you want is not listed, you can add the data source to the ODBC Data Sources dialog box, and from there add it to the Select Data Source dialog box.  You can add data sources from within Microsoft Query (used by Access, Excel and Word for Windows) or from the ODBC Control Panel.  To add a data source to the ODBC Data Sources dialog box, its ODBC driver must already be installed on your machine.


(	Open the Control Panel 


(	Click on the ODBC icon to see the list of data sources available.  This runs \windows\system\odbcadm.exe.  Built-in drivers have been provided for the following types of data:


Microsoft Access version databases


Microsoft Foxpro version 2 and 2.5 database files


Paradox version 3 and 4 tables


dBase III and IV files


Btrieve tables


Microsoft Excel and Lotus 1-2-3 spreadsheets


Fixed-width and delimited test files


Microsoft Word for Windows mail merge data files (export only)


To install built-in drivers, use the Microsoft Access Setup program.  If you select Custom from the Complete menu and then choose ISAM driver, the Setup program lists the drivers you can install.  Microsoft Access supports Microsoft Excel, Lotus 1-2-3, text and Word for Windows - you do not need to install drivers for these types of data.


To install ODBC drivers to access ORACLE data held on ISIS or a departmental sun with ORACLE mounted on it:


(	Click on Add.


(	Click on ORACLE.


(	Click on OK.


(	Data Source name is set to ‘isis’.


(	Description is set to ‘isis’.


(	SQL*NET Connect string is set to ‘isis’ where sid is the identifier of the ORACLE database.


(	Click on OK.


You will notice that a new data source has been added ‘isis (Oracle)’ to enable you to access ORACLE data on ISIS.  You will also have to install SQL*NET as described in Reference A. 


\windows\odbc.ini holds the information on each data source setup.


Adding Data Sources from within Microsoft Query


MS Query is the query module used by Access .  It is entered from Word (after you have chosen Database from the Insert menu) and Excel (after you have chosen Get External Data from the Data menu) to query Access and ORACLE data.  It does not involve duplicating data since it is accessed at source.


(	In the Select Data Source dialog box choose the Other button.  The ODBC Data Sources dialog box is shown.


(	Choose the New button.  Microsoft Query displays the Add Data Source dialog box. 


(	In the Installed ODBC Drivers box, select the driver for the data source that you want to add to the ODBC Data Sources dialog box.


(	Press OK.  Microsoft Query displays a Setup dialog box specific to the data source that you are adding as described above.  The name that you assign to the data source is the name that appears in the Data Sources dialog box.


Attaching external data from Access


Access Security


 By default with Microsoft Access - there is a check box for the 'Save login ID and password locally' which is unchecked, but which the user can change, giving the potential consequences as detailed above. Encryping the database is another option to protect the passwords. This possibility may exist when using other products, so it is advisable to look out for the default options.


Using Microsoft Access to get to your Oracle data.


There are 2 options:


You can download the Oracle tables into an Access database or you can use an external link to the Oracle tables. Downloading the tables will enable more speedy access to the data but it creates a snapshot of the tables which may be subsequently modified in Oracle and will therefore be out-of-date in Access.


Creating external links to Oracle tables keeps the Access view up-to-date and has the added advantage of not requiring extra storage space within the Access database.


When you attach or download an Oracle table, a list of Oracle tablenames appears in the format  ownername.tablename


The list only includes those tables that the Oracle ID has access to. Oracle system (public) tables such as User_tables and Session_roles are also excluded unless the Show System Options box is ticked within the view, options menu. Trying to view the Oracle system tables in Access can cause an ODBC fail with the message: ORA-01741 - illegal zero-length identifier.


It is only possible to download or attach to one Oracle table at a time, which make life tedious if you have a lot to do.


Editing and updating attached Oracle tables within Microsoft Access is very easy. The only condition is that the Oracle table must have a unique index. If this does not exist on the Oracle table, for example if you are looking at an Oracle view, then you can create a unique index within Access that Oracle is not aware of, by using a data-definition query.


(	From the File menu choose Attach.


Possible Data sources are:


Microsoft Access 


Paradox version 3 and 4


Foxpro version 2


dBase III and IV


Btrieve


<SQL Database> (that is, ORACLE or SQL Server)


Depending on the data source, a different symbol prefixes the name of the attached table.  If you look at the design of the table (which can not be changed) and look at the properties you can see the source of the table.  All attached tables are shown by a bold right arrow.  dBase tables also show a bold ‘dB’, ORACLE tables a globe


If you are attaching an ORACLE table, you will be asked to select a Data Source.  Although ORACLE data sources will be shown, it will also show dBase, Access (choose between version 1 or 2), Paradox, Foxpro or the Nwind Access demonstration database.


(	Click on isis.


(	Click on OK.


(	You are asked to logon to ORACLE by giving an ORACLE username and  password.  Note that this is not your isis username and password.  If you want to find out your own ORACLE username and password you will have to ask Maggie Shapland.  You can use username ‘scott’, password ‘tiger’ for demonstration.


(	Click on OK.


(	The tables that may be attached are displayed.  They are prefixed by the username that they belong to since you may have been given access to other peoples tables.  If you want to save the ORACLE username and password locally so that you will not be asked for it when you next access the attached tables, click on the Save ID and password locally box.  Highlight the tables (one at a time) that you want to attach and press OK.


Attached tables are slower to access than locally stored tables, and their design can not be changed.  They do however avoid duplication of data since the data is held in one place.


(	From the File menu choose Add-in.  Attachment Manager allows you to view or refresh attachments if the attached table’s structure has been changed.


Points to note:


¨	ORACLE tables must be set up with primary keys (by using ‘create unique index’ from SQLPLUS) if you want to be able to add data from Access.


¨	You can perform ‘pass-through’ queries from Access.  This allows you to use ORACLE SQL instead of Access SQL to query the ORACLE tables.  This avoids Access SQL being converted into ORACLE SQL so is more efficient.  It also allows you to do SQL queries such as nested queries, and to create tables.


¨	You can’t set up automatic counters.


¨	If you are using a 4Mb machine, you find Access very slow.  Do not type ahead else you will find that data will end up in the wrong cell.


¨	Since you can not change the table definition, and ORACLE version 6 does not enforce data validation (except for null values and non-unique primary keys), you will have to build validation into your Access forms.  Relationships are built automatically in Access version 2 if you use the same field names and data types, but you can set up relationships.


¨	Searches on ORACLE data are case-sensitive from Access even if case sensitivity is off.


¨	ORACLE field and table names can not contain spaces and are limited to 30 characters.  You may not have more than 240 fields in a table.  There are also many reserved words that you may not call a table or field such as ‘group’, ‘comment’, so if you are thinking of creating a table in Access and exporting it to ORACLE later, you should bear this in mind.


¨	Access Fields containing OLE objects will not successfully be imported into the ORACLE longraw datatype since it only holds 65Kb so the picture will come out very fuzzy.


¨	ORACLE does not save data until the user issues a request to commit it (in SQLPLUS you can ask for changes to be saved automatically by means of the autocommit statement.  Access saves changes as you leave the record so does not support rollback.


¨	The Access driver evaluates the where clause as it fetches each row.  If a row contains a value that causes an arithmetic error such as dividing by zero, the driver returns all the rows but returns errors for the fields with the arithmetic errors.  ORACLE would just return an error.


¨	If you are updating a table and you get an error, Access will tell you how many rows will be updated, and then tell you that there are errors.  If you choose to continue, the invalid values will be set to null.  ORACLE only returns an error message and will not allow you to continue.


Oracle 7 relationships are visible when attached into an Access database.


Sending Access data to other packages


Alternative methods of transferring Access data:


(	From the File menu choose Add-in.  The Import Manager will import a whole Access database from another Access application.


(	From the File menu choose Export.  The formats that can be chosen are:


Access (individual tables)


Text delimited


fixed text


Excel


Word for Windows merge (to be used in mailmerge)


Lotus WK1 and WKS


Excel version 2-5


Paradox 3, 4


Foxpro 2.0-2.5


dBase III,IV


Btrieve


<SQL database> (ORACLE )


Note that if you use spaces in an Access field name and you are exporting to Word or ORACLE, that the space will automatically be replaced by an underscore.  If  the name of the table or field was in lower in Access it will stay as lower case in ORACLE and you will have to use double quotes around its name to access it.


(	Create a report using the mailmerge wizard.


(	From the File menu choose Output to, to output in text (no formatting) rich text for Word (includes formatting and fonts) or Excel format.  This method retains fonts and formatting. 


Excel version 5


Excel Security


Interestingly, these Microsoft products deal with password security to external databases in opposite ways. The following provides a security warning for those querying ORACLE from Excel using ODBC middleware. 


Querying ORACLE from Excel


Querying ORACLE from Excel poses a possible security problem to do with the query definition being saved along with the data in the spreadsheet.


When you query ORACLE from Excel, you are taken into MS-QUERY, where you are asked for your ORACLE id and password. You then select the table(s) to query, and when you have the data you require, you then select  'Return data to Excel'.


The important thing is the next box which appears. By default, an item 'Keep query definition' is checked. If you leave this checked then the query definition, along with the information needed to re-connect to ORACLE, ie the userid and password, is saved with the spreadsheet.


This is a useful facility, as it means that if you call up the sheet at some later date, and select 'Get external data', you will not be asked for your ORACLE id and password, and the query you used to select the data on the spreadsheet will be used to re-query the database. 


This is a very nice feature, meaning you can update the data on the spreadsheet with the revised data in the database with the minimum of effort. The problem of course, is that it offers NO security. 


If someone else had access to that spreadsheet, they would also gain the same access to the ORACLE table(s) accessible to the userid which was used. This could  potentially be very serious, particularly if you copy spreadsheets around.


The way to plug this loophole is to remember to uncheck the box marked 'Keep query definition' when you return the data to the spreadsheet. This will of course mean that when you wish to update the data, you will have to provide all the information (login id/password and query) again.


(	From the Data menu choose Get External Data to start Microsoft Query.


The data source window shows available data sources (ORACLE sources show the username that you used).


(	Highlight a data source and press Use.


(	If the source is ORACLE, give the ORACLE username and password when requested.


(	If a wanted data source is not displayed, press Other.


(	Choose an ODBC data source.


(	If the required data source is not shown press New and create as described above.


(	Press OK.


(	Highlight the new data source and press Use.


(	The accessible tables will be shown.  Create a query definition by adding the appropriate tables.


(	Press Close to stop adding tables.


(	Use the Criteria menu to give criteria or choose Criteria from the View menu to display the criteria section.


(	From the File menu, choose Return data to Excel.


(	In the destination box type or select the reference for the upper left cell of the range where you wish the results to appear (you can save the query by selecting the Keep Query Definition box).


(	Choose OK.


To embed an Excel object in another application, use Copy and Paste Special.  This can not be used for ORACLE. 


If you select Save As from the File menu, you will have to save in comma delimitered format to mailmerge into Word or import into ORACLE.  Access can import Excel spreadsheets.


Excel version 4


Use the QE.XLA add in, then from the Data menu choose Activate Q+E.  You must then use SQL to construct your query.


Word For Windows 2


There is no ODBC link.  You can only insert Excel worksheets into a Word document.  Use Copy and Paste Special between Microsoft applications.  Access data has to be incorporated using mailmerge.


Word For Windows 6


(	From the Insert menu choose Database.


(	Select Get Data.


(	From the Open Data Source window select MS Query.


(	The available data sources are listed.  Either select Use to use one, or select Other and add a new source as described above, and then Use that.


(	Logon to ORACLE by giving your ORACLE username and password.  Username scott and password tiger will get you the demonstration tables.


(	You are now in MS Query.  Choose the tables that you want by highlighting them and pressing Add Table.


(	Close when you have chosen all your tables.


(	Create your query, in the same way as you would using Access query.


(	Exit by choosing Return Data from the File menu.


(	From the Database window, click on Insert Data.  You now have the choice of returning all records, or a selected number.


(	Click on OK.


You will get a General Protection Fault if you try to insert ORACLE data.  This is a problem due to the Winsock driver and may be got round using PSNFS4 or 3rd party ODBC software.


ORACLE


ORACLE is a multiuser relational database management system.  ORACLE is held on isis, and adm1 and any departmental sun that has a licence.  It is held on adm1 but Administrative Computing do not allow staff to access ORACLE  for security reasons.  Although it is possible to put ORACLE on your PC, it is not possible to link it to other software in the way described in this document.  You can access ORACLE data from Access and Excel version 5, so you can still use an interface that is familiar to you.  Currently you get a general protection fault when you try and embed ORACLE data into Word for Windows version 6.


You should be using ORACLE to store your data:


¨	if you wish to share it


¨	if you have a large amount of data


¨	you want to take advantage of the enhanced ORACLE SQL to do more complex queries


The ORACLE driver enables applications to access data in an ORACLE database through the Open Database Connectivity (ODBC) interface.  It communicates with the network through SQL*Net.


�
Architecture


Application


|


ODBC Driver Manager (ODBC.DLL)


|


ORACLE Driver (SQORA..DLL)


|


OCI Layer (ORA6WIN.DLL)


|


SQL*NET TCP/IP For Windows Driver


|


Network Software (PC-NFS Windsock)


|


SQL*Net Listener on remote machine


|


ORACLE Server
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